注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

obsolete

wanna go

 
 
 

日志

 
 

注解@Override导致的 the method must override a superclass method 原因  

2014-03-06 15:40:41|  分类: kfgj开发工具 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

实现类里面使用了 @Override

在1.5下要使用@Override 这个annotation 必须保证 被标注方法来源于class 而不是interface


所以eclipse里面修改配置

将java compiler compliance level设为1.6

如图

注解@Override导致的 the method must override a superclass method 原因 - readwall - obsolete

 

  评论这张
 
阅读(369)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018